Nigeria: Direct Debit Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 11:12 CET

Investigating

We are currently experiencing a downtime on the Direct Debit channel. As a result, you may encounter errors when attempting to debit an account.

What does this mean for you?
- Attempts to charge bank accounts via Direct Debit may fail.
- Attempts to link bank accounts may also fail.

Next Steps:
We're actively investigating and monitoring the situation and will provide updates as we receive more information.
Posted Jul 10, 2025 - 18:24 CET
This incident affected: Transactions (Direct Debit).