Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 07, 2025 - 22:00 CET
Scheduled
Due to some urgent maintenance, the Direct Debit account linking service will be temporarily unavailable today between 10:00 PM and 11:00 PM WAT. During this period, your customers will not be able to link their accounts for recurring payment.
However, initiating a direct debit charge will continue to work normally, same with all other payment channels. Normal operations will resume immediately after the maintenance is completed
Posted Mar 07, 2025 - 20:14 CET
This scheduled maintenance affected: Transactions (Direct Debit).