Delay in processing some Paystack Transfers
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Oct 12, 2022 - 15:24 CET
Investigating
Due to a technical disruption, transfers to Access Bank accounts in Nigeria might be experiencing a slight delay. We are working with our partners to resolve this issue as quickly as possible and will provide an update as soon as the issue has been resolved.
Posted Oct 12, 2022 - 12:31 CET
This incident affected: Transfers.