Wix Integration Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 19:15 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 18:04 CET

Investigating

Our partner, Wix, is currently experiencing issues with our integration on their platform, which is affecting merchants who use Paystack on their Wix websites. As a result, some customers are unable to complete payments at checkout.

We’re actively liaising with the Wix team to resolve the issue and restore full service as soon as possible. We’ll continue to share updates here as we learn more.
Posted Jul 14, 2025 - 16:25 CET
This incident affected: Transactions (Cards).