South Africa: Increase in 3DS failures for Nedbank-issued cards
Incident Report for Paystack
Resolved
Nedbank has confirmed that service has been restored.
Posted Feb 02, 2024 - 13:15 CET
Investigating
We are seeing an increased rate of failure for 3DS transactions using Nedbank-issued cards. It has been escalated to our 3rd party partners.
Posted Feb 02, 2024 - 12:46 CET
This incident affected: Transactions (Cards).