South Africa: Degraded Apple Pay performance

Incident Report for Paystack

Resolved

Transaction success rates have returned to normal.
Posted May 23, 2025 - 12:21 CET

Investigating

We are seeing an increase in Apple Pay failures. We are busy investigating the issue.
Posted May 23, 2025 - 11:47 CET
This incident affected: Transactions (Apple Pay).