South Africa: Elevated failure rates for Investec-issued cards
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Nov 24, 2023 - 16:24 CET
Monitoring
Success rates for Investec-issued cards have stabilised. We will continue to monitor.
Posted Nov 24, 2023 - 12:30 CET
Investigating
We are seeing an increased rate of failure for 3DS authentications for cards issued by Investec. The issue has been escalated to our 3rd-party partners.
Posted Nov 24, 2023 - 11:17 CET
This incident affected: Transactions (Cards).