South Africa: Increase in 3DS transaction failures

Incident Report for Paystack

Resolved

Success rates have been stable again since 21:30.
Posted Mar 30, 2025 - 20:54 CET

Identified

Bankserv is experiencing network issues. We have seen some improvement over the last 30 minutes, but success rates are not back to normal yet.
Posted Mar 30, 2025 - 20:31 CET

Investigating

We're seeing an increase in 3DS transaction failures. We have escalated the issue to our 3rd party partners.
Posted Mar 30, 2025 - 19:25 CET
This incident affected: Transactions (Cards, QR).