South Africa: Transfers failing
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 07:06 CET
Identified
We have identified an issue that is causing transfers in South Africa to fail. We are working with our 3rd-party partners to resolve it.
Posted Apr 02, 2024 - 13:00 CET
This incident affected: Transfers.