Ghana: AirtelTigo System Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 16:01 CET

Investigating

We're currently experiencing a downtime with our partner, AirtelTigo, which is affecting mobile money transactions. As a result, most AirtelTigo transactions are failing. We're currently liaising with them to fix the issues and restore the service.
Posted Jun 25, 2025 - 11:25 CET
This incident affected: Transactions (Mobile Money).