South Africa: 3D Secure
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 28, 2023 - 10:28 CET
Monitoring
3D Secure transactions are processing normally again. We will continue to monitor.
Posted Apr 28, 2023 - 09:50 CET
Investigating
We are seeing an increase in errors for 3D Secure transactions. The issue has been escalated to Bankserv.
Posted Apr 28, 2023 - 06:54 CET
This incident affected: Transactions (Cards, QR).