Ghana: Downtime on MTN Ghana Mobile Money Transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Oct 16, 2024 - 00:15 CET

Investigating

Our partner MTN Ghana is currently experiencing an issue affecting Mobile Money transactions in Ghana. We're currently liaising with them to fix the issues and restore the service and will provide an update as soon as possible.
Posted Oct 15, 2024 - 09:30 CET
This incident affected: Transactions (Mobile Money).