We are continuing to monitor for any further issues.
Posted Apr 23, 2025 - 14:28 CET
Monitoring
We're closely monitoring the situation and will share an update as soon as it's resolved.
Posted Apr 16, 2025 - 12:38 CET
Investigating
We're currently experiencing delays with the Direct Debit account linking service due to an issue with one of our partners.
What this means: Customers may be unable to link new bank accounts at this time, or may notice delays during the linking process. Previously linked accounts remain unaffected and can still be charged as usual.
We're actively working with our partner to resolve this and will share updates as soon as we have more information.
Posted Apr 16, 2025 - 11:09 CET
This incident affected: Transactions (Direct Debit).