Nigeria: Downtime on 737 transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Jul 26, 2023 - 15:24 CET
Investigating
We are currently investigating an issue affecting payments made via our 737 USSD payment channel, and are working diligently with our partners to resolve the issue. Updates will be provided as we progress. Thank you for your understanding and patience
Posted Jul 25, 2023 - 15:22 CET
This incident affected: Transactions (USSD).