Nigeria: Downtime on Zenith Bank Transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jun 29, 2025 - 08:07 CET

Investigating

We are seeing an increase in failure rates on Zenith Bank transactions. This is due to a downtime at the bank.

We have notified the Zenith bank team and are in close contact with them to resolve this issue as quickly as possible.
Posted Jun 29, 2025 - 05:42 CET
This incident affected: Transactions (Cards, Pay with Transfer/EFT, Direct Debit) and Transfers.