Nigeria: Downtime on Zenith Bank transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jul 26, 2025 - 22:11 CET

Investigating

We’re currently experiencing downtimes from Zenith Bank affecting Direct Debit and card transactions.

As a result, you may encounter errors when attempting to debit accounts from Zenith bank.

What does this mean for you?
- Attempts to charge bank accounts issued by Zenith Bank via Direct Debit may fail.
- Direct Debit via other banks remain unaffected.
- Cards issued by Zenith bank may experience failure.

We’re actively monitoring the situation and will provide updates as we receive more information from our banking partners.
Posted Jul 26, 2025 - 17:31 CET
This incident affected: Transactions (Cards, Pay with Transfer/EFT, Direct Debit) and Transfers.