Nigeria : Outage on Paystack Direct Debit

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted May 24, 2025 - 08:43 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 12:13 CET

Investigating

Direct Debit is currently unavailable across all banks. Debits on already‑linked accounts are failing.

Our team is investigating with the service provider and will provide updates shortly
Posted May 23, 2025 - 06:37 CET
This incident affected: Transactions (Direct Debit).