A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 14:49 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 14:41 CET
Investigating
Please note that we are aware of an increase in error responses across a host of Paystack products. We are actively investigating the cause of this issue and will update this incident as the investigation progresses.
Posted Jun 18, 2025 - 13:41 CET
This incident affected: API, Checkout, Transfers, Payment Page and Transactions (Cards, Pay with Transfer/EFT, Virtual Account Numbers, Mobile Money, QR, USSD, Direct Debit, Apple Pay).