South Africa: Increase in 3D-Secure transaction failures
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 21, 2024 - 09:27 CET
Monitoring
3DS success rates have returned to normal since 9:33 SAST. We will continue to monitor.
Posted Apr 21, 2024 - 08:53 CET
Identified
We're currently seeing an increased rate of failure for 3D Secure transactions. The issue has been escalated to our 3rd-party partners and they are working on restoring the service.
Posted Apr 21, 2024 - 06:45 CET
This incident affected: Transactions (Cards, QR).