Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 21, 2025 - 22:30 CET
Scheduled
Our mobile money partner, M-PESA will undergo a system maintenance from 22nd September 2025 00:30 to 22nd September 2025 03:30 EAT.
During that time, all M-PESA services will be unavailable .i.e customers will not be able to make payments or receive disbursements via Paystack on M-PESA.
However, other payment methods such as cards and other mobile money services, as well as disbursements to bank accounts and other mobile money accounts, will not be affected.
Posted Sep 19, 2025 - 09:03 CET
This scheduled maintenance affected: Transactions (Mobile Money).