[Nigeria] Verve Card Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 10:32 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2025 - 09:39 CET

Investigating

We are currently experiencing issues with processing Verve card transactions as a result of a downtime with a processing partner. As a result, attempts to make card payments with Verve cards may fail.

You can still receive payments using other cards, such as Mastercard or Visa. Other payment methods also remain unaffected.

We are in touch with our processing partner and are actively trying to resolve this. We will share an update once we have feedback from our partner.
Posted Sep 12, 2025 - 18:48 CET
This incident affected: Transactions (Cards).