South Africa: Connectivity Issues Affecting Multiple Channels
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 06:44 CET
Monitoring
It is looking stable again. We will continue to monitor.
Posted Mar 14, 2024 - 17:10 CET
Identified
A number of our 3rd-party partners are currently affected by connectivity issues caused by submarine cable outages. This is having an impact on our success rates across multiple channels.
Posted Mar 14, 2024 - 13:49 CET