Nigeria: Delay in Processing Inward Transfers to Wema Bank Accounts

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Aug 30, 2025 - 17:55 CET

Investigating

We are currently experiencing a delay in processing inward transfers to dedicated accounts issued by Wema Bank. We are in contact with the Wema Bank team and will share an update as soon as possible.

Paystack Titan virtual accounts remain unaffected for both Pay with Transfer (PWT) and Dedicated Accounts.
Posted Aug 29, 2025 - 19:42 CET
This incident affected: Transactions (Virtual Account Numbers).