South Africa: Scan to Pay Transactions Failing

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Sep 06, 2025 - 06:52 CET

Monitoring

Connectivity was restored just after 07:00 SAST. Transactions are processing normally again. We will continue to monitor.
Posted Sep 06, 2025 - 06:19 CET

Identified

EFT Corp, our QR payments provider, is currently experiencing connectivity issues. Their team is actively working on addressing the issue.
Posted Sep 06, 2025 - 01:36 CET

Investigating

Scan to Pay and Snapscan transactions are currently failing. It has been escalated to our third-party partners.
Posted Sep 06, 2025 - 01:19 CET
This incident affected: Transactions (QR).