South Africa: Degraded Capitec card performance

Incident Report for Paystack

Resolved

Success rates have been stable since 9:48 SAST.
Posted Jul 23, 2025 - 09:14 CET

Investigating

We are seeing an increased rate of failure for 3DS transactions using Capitec-issued cards. The issue has been escalated to our 3rd party partners.
Posted Jul 23, 2025 - 07:28 CET
This incident affected: Transactions (Cards).