South Africa: Increased rate of failures for 3DS transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 02:08 CET
Investigating
We are seeing an increased rate of failure for 3DS transactions in South Africa. The issue has been escalated to our 3rd party partners.
Posted Dec 11, 2023 - 22:03 CET
This incident affected: Transactions (Cards).