Ghana: Downtime on Transfers to CAL Bank
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 11:29 CET
Investigating
All Bank Transfers to CAL Bank accounts are failing due to an ongoing issue with the bank’s internal systems.
CAL Bank & GhIPSS teams have been engaged to restore the service as quickly as possible. We will provide an update as soon as it has been resolved.
Posted Nov 05, 2024 - 15:04 CET
This incident affected: Transfers.