Nigeria: Direct Debit Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 08:13 CET

Monitoring

We are seeing improvements and are currently monitoring for consistency.
Posted May 26, 2025 - 20:40 CET

Investigating

We are currently experiencing a downtime on the Direct Debit channel. As a result, you may encounter errors when attempting to debit an account.

What does this mean for you?
- Attempts to charge bank accounts via Direct Debit may fail.

Next Steps:
We're actively monitoring the situation and will provide updates as we receive more information from our partners.
Posted May 26, 2025 - 19:25 CET
This incident affected: Transactions (Direct Debit).