Errors on completing transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Dec 01, 2020 - 21:39 CET
Investigating
We are currently experiencing high response times/increased latency on our charge endpoint. As a result, customers making payments might face some errors in completing their transactions. Our Engineering Team is looking into this and we'll provide updates shortly.
Posted Dec 01, 2020 - 20:30 CET
This incident affected: API and Checkout.