Issue viewing payouts on the Paystack Dashboard
Incident Report for Paystack
Resolved
This issue has now been resolved. Payouts have been made to merchants with payouts in Naira and payouts in Ghana Cedis for merchants with mobile money payout accounts.

For payouts in US Dollars, South African Rand and Ghanaian Cedis (for merchants with payout bank accounts), we've processed payouts but it's likely the banks will process this on Monday. Sincere apologies for this experience. We're making changes to ensure this doesn't happen again.
Posted Nov 27, 2020 - 18:00 CET
Update
We have been able to fix this issue for merchants expecting payouts in Nigerian Naira (NGN) and we'll soon begin processing payouts. For other currencies, the team is still working on a fix and we'll provide an update as soon as there's a change.
Posted Nov 27, 2020 - 14:45 CET
Identified
We've identified an issue where payouts for November 27, 2020 isn't reflecting on the Paystack Dashboard. Merchants on manual payouts might experience delays in their payouts reflecting in their balance. Our Core Payments team is working on this issue and we'll have a fix shortly.

We don't expect this to affect payouts for merchants who are on the automated payout schedule.
Posted Nov 27, 2020 - 09:57 CET