South Africa: Nedbank degraded performance

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Feb 15, 2025 - 17:45 CET

Monitoring

Success rates have been stable since 14:15 SAST. We will continue to monitor.
Posted Feb 15, 2025 - 13:38 CET

Identified

Nedbank performance has degraded again. We have escalated the issue.
Posted Feb 15, 2025 - 13:03 CET
This incident affected: Transactions (Cards, QR).