Global: Manual payout delays
Incident Report for Paystack
Resolved
This issue has been resolved. All businesses should now see their payouts reflected in their balances (for Nigerian businesses) or deposited into their bank accounts (for businesses in other countries).

If you continue to experience any issues, please contact our support team at support@paystack.com, and we’ll be happy to assist.
Posted Sep 13, 2024 - 14:40 CET
Identified
We have identified the issue causing manual payout delays and are currently implementing a fix. This will ensure that payouts for businesses in Nigeria are correctly applied to their balances.

For businesses outside Nigeria, our treasury team has successfully settled all pending manual payouts directly into bank accounts to minimize further delays. As a result, balances for these transactions will not be updated today but will reflect tomorrow once the fix is fully implemented.

Starting tomorrow, payouts across all markets will be processed and reflected in balances as usual.

Thank you for your patience as we work to resolve this issue.
Posted Sep 13, 2024 - 14:01 CET
Investigating
We are currently investigating an issue causing delays in manual payouts for some businesses. Our engineering team is actively working on a solution, and we expect to resolve the issue shortly. Thank you for your patience as we work to restore full functionality.
Posted Sep 13, 2024 - 11:01 CET