Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 10, 2024 - 23:00 CET
Scheduled
Nedbank will be conducting planned maintenance on Sunday, 11 August 2024 from 00:00 to 06:00 SAST. What does this mean for you?
During the maintenance from 00:00 to 06:00, there will be downtime for 10 to 15 minutes shortly after midnight that will impact card, Scan to Pay and Snapscan payments.
Apple Pay and Ozow EFT will be unaffected during these times.
We recommend that you update members of your team and consider preemptively informing your customers about the service disruptions.
Posted Aug 08, 2024 - 13:55 CET
This scheduled maintenance affected: Transactions (Cards, QR).