Delay in Completing Transfers
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 03:18 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2024 - 19:03 CET
Identified
Transfers to bank accounts in Nigeria might experience a slight delay due to a downtime from one of our technical partners.

There might also be a delay in confirmation of deposits for transactions, top ups and Dedicated Virtual Accounts.

We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Mar 14, 2024 - 12:29 CET
This incident affected: Transfers.