Paystack - Ghana: Ghipss System Downtime – Incident details

All systems operational

Ghana: Ghipss System Downtime

Resolved
Major outage
Started 1 day agoLasted about 1 hour

Affected

Transfers

Major outage from 4:13 PM to 5:09 PM

GHANA

Major outage from 4:13 PM to 5:09 PM

Bank

Major outage from 4:13 PM to 5:09 PM

Mobile Money

Major outage from 4:13 PM to 5:09 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    We are currently experiencing an issue with Transfers due to downtime on Ghipss platform. This is causing most transfers to fail.

    Our team is in active communication with Ghipss, and we are working closely with them to restore full service as quickly as possible. We’ll share further updates as soon as they are available.