Paystack - Kenya: Mpesa Intermittent Downtime – Incident details

Direct Debit experiencing degraded performance

Kenya: Mpesa Intermittent Downtime

Resolved
Degraded performance
Started about 7 hours agoLasted about 7 hours

Affected

Transactions

Operational from 8:08 AM to 8:53 AM, Degraded performance from 8:53 AM to 2:40 PM

KENYA

Operational from 8:08 AM to 8:53 AM, Degraded performance from 8:53 AM to 2:40 PM

M-PESA

Operational from 8:08 AM to 8:53 AM, Degraded performance from 8:53 AM to 2:40 PM

Transfers

Degraded performance from 8:08 AM to 12:24 PM, Operational from 12:24 PM to 2:40 PM

KENYA

Degraded performance from 8:08 AM to 12:24 PM, Operational from 12:24 PM to 2:40 PM

M-PESA

Degraded performance from 8:08 AM to 12:24 PM, Operational from 12:24 PM to 2:40 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently experiencing an issue with Mpesa transactions due to intermittent downtime on Mpesa's platform. This is causing some Mpesa payments to fail.

    Our team is in active communication with Mpesa, and we are working closely with them to restore full service as quickly as possible. We’ll share further updates as soon as they are available.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We are currently experiencing an issue with Mpesa transactions due to downtime on Mpesa's platform. This is causing most Mpesa payments to fail.

    Our team is in active communication with Mpesa, and we are working closely with them to restore full service as quickly as possible. We’ll share further updates as soon as they are available.