Paystack - Nigeria: Degraded Performance on Direct Debit – Incident details

All systems operational

Nigeria: Degraded Performance on Direct Debit

Resolved
Degraded performance
Started 4 days agoLasted 4 days

Affected

Transactions

Degraded performance from 12:30 PM to 7:58 AM

NIGERIA

Degraded performance from 12:30 PM to 7:58 AM

Direct Debit

Degraded performance from 12:30 PM to 7:58 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    The Central Switch has stabilised and we are currently monitoring performance.

  • Investigating
    Investigating

    There is an elevated rate of timeouts affecting Direct Debit from the Central Switch. This affects charging already linked accounts and linking new accounts. We are working with them to improve performance.