Paystack - Kenya: MPESA System Downtime – Incident details

M-PESA experiencing major outage

Kenya: MPESA System Downtime

Monitoring
Major outage
Started about 10 hours ago

Affected

Transactions

Major outage from 10:21 AM to 12:00 AM

KENYA

Major outage from 10:21 AM to 12:00 AM

M-PESA

Major outage from 10:21 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    Our partner, MPESA, is currently having a downtime on their platform, which is affecting mobile money transactions. As a result, most MPESA STK PUSH transactions are failing. However, transactions via Paybill are successful.

    We're currently liaising with them to fix the issues and restore the service.