Paystack - Ghana: MTN System Downtime – Incident details

All systems operational

Ghana: MTN System Downtime

Resolved
Degraded performance
Started 7 days agoLasted about 11 hours

Affected

Transactions

Degraded performance from 7:36 PM to 6:35 AM

GHANA

Degraded performance from 7:36 PM to 6:35 AM

Mobile Money

Degraded performance from 7:36 PM to 6:35 AM

Transfers

Degraded performance from 7:36 PM to 6:35 AM

GHANA

Degraded performance from 7:36 PM to 6:35 AM

Mobile Money

Degraded performance from 7:36 PM to 6:35 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are monitoring the service.

  • Investigating
    Investigating

    Our partner, MTN, is currently having a downtime on their platform, which is affecting mobile money transactions at the moment. As a result, most MTN transactions are failing. We're currently liaising with them to fix the issues and restore the service.