Paystack - Ghana: MTN System Downtime – Incident details

All systems operational

Ghana: MTN System Downtime

Resolved
Degraded performance
Started 12 days agoLasted about 14 hours

Affected

Transactions

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Our partner, MTN, is currently having a downtime on their platform, which is affecting mobile money transactions at the moment. As a result, most MTN transactions are failing. We're currently liaising with them to fix the issues and restore the service.