Paystack - [Nigeria] Delays in Receiving Funds into Wema Dedicated Virtual Accounts (DVA) – Incident details

QR under maintenance

[Nigeria] Delays in Receiving Funds into Wema Dedicated Virtual Accounts (DVA)

Resolved
Degraded performance
Started 4 days agoLasted about 23 hours

Affected

Transactions

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    The issue has now been resolved, and there should no longer be delays in receiving funds into Wema Dedicated Accounts. However, there is still a backlog of incoming funds that the bank is working through. These will all be processed over the next few hours and we apologize for the continued inconvenience.

  • Investigating
    Investigating

    We are experiencing a delay with receiving funds into Wema Dedicated Accounts as a result of a downtime with the bank. This means that funds transferred into these accounts might take a longer time than usual to reflect. Paystack-Titan and other Dedicated Account providers remain unaffected, and you can continue to receive funds into accounts issued by them. We are in communication with Wema bank and will share an update when the issue is resolved. We apologize for any inconvenience this might cause.