Paystack - Nigeria: Delay in Completing Inward Transfers to Paystack Titan accounts – Incident details

All systems operational

Nigeria: Delay in Completing Inward Transfers to Paystack Titan accounts

Resolved
Degraded performance
Started 3 days agoLasted about 2 hours

Affected

Transactions

Degraded performance from 8:28 PM to 10:28 PM, Operational from 8:28 PM to 10:28 PM

NIGERIA

Degraded performance from 8:28 PM to 10:28 PM, Operational from 8:28 PM to 10:28 PM

Bank Transfer

Degraded performance from 8:28 PM to 10:28 PM

Direct Debit

Operational from 8:28 PM to 10:28 PM

Transfers

Degraded performance from 8:28 PM to 10:28 PM, Operational from 8:28 PM to 10:28 PM

NIGERIA

Degraded performance from 8:28 PM to 10:28 PM, Operational from 8:28 PM to 10:28 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Identified
    UTC
    Identified

    We are currently experiencing a downtime with the central switch in Nigeria. As a result, you may notice delays in completing inward transfers to Paystack Titan managed accounts via both Pay with Transfer (PwT) and Dedicated Virtual Accounts (DVA).

    We are actively working to resolve this issue and will provide updates as soon as we have them. We apologize for any inconvenience this might cause