Paystack - Nigeria: High Failure Rate on Account Linking for Direct Debit – Incident details

All systems operational

Nigeria: High Failure Rate on Account Linking for Direct Debit

Resolved
Major outage
Started 3 days agoLasted 2 days

Affected

Transactions

Major outage from 1:00 PM to 11:29 AM

NIGERIA

Major outage from 1:00 PM to 11:29 AM

Direct Debit

Major outage from 1:00 PM to 11:29 AM

Updates
  • Resolved
    UTC
    Resolved

    We have implemented a temporary fix, while we work with the Central provider to resolve the underlying issue. Customers are now able to link their account successfully

  • Investigating
    UTC
    Investigating

    We are currently experiencing an issue with the verification service used for Direct Debit mandate creation, preventing customers from linking new bank accounts. We are actively working with the central provider to resolve this as quickly as possible. We apologize for any inconvenience caused.