Paystack - Nigeria: Delay in Completing Bank Transfers and Receiving Inward Credits into Paystack Titan accounts – Incident details

All systems operational

Nigeria: Delay in Completing Bank Transfers and Receiving Inward Credits into Paystack Titan accounts

Resolved
Degraded performance
Started about 5 hours agoLasted about 1 hour

Affected

Transactions

Degraded performance from 11:08 AM to 12:04 PM, Operational from 11:08 AM to 12:04 PM

NIGERIA

Degraded performance from 11:08 AM to 12:04 PM, Operational from 11:08 AM to 12:04 PM

Bank Transfer

Degraded performance from 11:08 AM to 12:04 PM

Direct Debit

Operational from 11:08 AM to 12:04 PM

Transfers

Operational from 11:08 AM to 12:04 PM

NIGERIA

Operational from 11:08 AM to 12:04 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently experiencing a downtime with the central switch in Nigeria. As a result, you may notice delays in transfers to Paystack Titan accounts and in processing outward transfers to all bank accounts.

    We're actively working with our partner to resolve this issue and will provide updates as soon as service is fully restored.

    We apologize for any inconvenience this might cause