Paystack - Ghana: MTN Intermittent USSD push downtime – Incident details

Experiencing partially degraded performance

Ghana: MTN Intermittent USSD push downtime

Identified
Degraded performance
Started about 6 hours ago

Affected

Transactions

Degraded performance from 4:00 PM to 7:39 PM, Operational from 7:39 PM to 12:00 AM

GHANA

Degraded performance from 4:00 PM to 7:39 PM, Operational from 7:39 PM to 12:00 AM

Mobile Money

Degraded performance from 4:00 PM to 7:39 PM, Operational from 7:39 PM to 12:00 AM

Transfers

Degraded performance from 4:00 PM to 7:39 PM, Operational from 7:39 PM to 12:00 AM

GHANA

Degraded performance from 4:00 PM to 7:39 PM, Operational from 7:39 PM to 12:00 AM

Mobile Money

Degraded performance from 4:00 PM to 7:39 PM, Operational from 7:39 PM to 12:00 AM

Updates
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We're currently experiencing intermittent issues with MTN Mobile Money transactions due to USSD push failures on MTN's platform. As a result, some customers may not receive the USSD prompt to authorize their payments, causing transactions to fail.

    Our team is in active communication with MTN, and we are working closely with them to restore full service as quickly as possible. We'll share further updates as soon as they are available.