Paystack - Kenya: MPESA System Downtime – Incident details

All systems operational

Kenya: MPESA System Downtime

Resolved
Major outage
Started about 3 hours agoLasted about 1 hour

Affected

Transactions

Major outage from 9:14 AM to 10:35 AM

KENYA

Major outage from 9:14 AM to 10:35 AM

M-PESA

Major outage from 9:14 AM to 10:35 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Our partner, MPESA, is currently having a downtime on their platform, which is affecting mobile money transactions. As a result, most MPESA STK PUSH transactions are failing. However, transactions via Paybill are successful. Please advise customers to make payments via MPESA paybill or other payment channels like Pesalink , Card or Airtel Money.

    We're currently liaising with them to fix the issues and restore the service.