Paystack - Nigeria: Paystack Direct Debit Creation Downtime – Incident details

All systems operational

Nigeria: Paystack Direct Debit Creation Downtime

Resolved
Partial outage
Started about 12 hours agoLasted about 7 hours

Affected

Transactions

Partial outage from 8:00 AM to 2:30 PM

NIGERIA

Partial outage from 8:00 AM to 2:30 PM

Direct Debit

Partial outage from 8:00 AM to 2:30 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    There's an issue with the central Direct Debit Mandate creation service. As a result, customers may be unable to link their bank accounts for Direct Debit. We are engaging with the central switch to fix this as soon as possible.

    We apologise for the inconvenience.