Paystack - Delay in Completing Transfers and Settlements – Incident details

M-PESA experiencing major outage

Delay in Completing Transfers and Settlements

Resolved
Degraded performance
Started 4 days agoLasted 1 day

Affected

Platform & Infrastructure

Operational from 6:23 PM to 8:42 AM, Degraded performance from 8:42 AM to 8:15 AM

Refunds

Operational from 6:23 PM to 8:42 AM, Degraded performance from 8:42 AM to 8:15 AM

Transactions

Degraded performance from 6:23 PM to 8:15 AM

NIGERIA

Degraded performance from 6:23 PM to 8:15 AM

Bank Transfer

Degraded performance from 6:23 PM to 8:15 AM

Transfers

Degraded performance from 6:23 PM to 8:15 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Transfers to bank accounts in Nigeria are currently experiencing a downtime. There is also confirmation of deposits for transactions, top ups and Dedicated Virtual Accounts.

    Settlements for transactions this morning are also delayed as a result of this.

    We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.

  • Update
    Update

    We have identified the cause of the downtime to be a problem with our connection to our processing partner. We're currently in communication with them, and will share updates as soon as possible.

    We apologize for any inconvenience this might cause.

  • Identified
    Identified

    We are currently experiencing a downtime with Pay with Transfer (PwT) and Outward Transfers. As a result, you may be unable to complete:

    1. PwT transactions to Paystack Titan accounts

    2. Outward transfers to some bank accounts

    Our team is actively working with partners to resolve this issue and will provide updates as soon as service is fully restored