Paystack - Nigeria: "Invalid transaction details" error – Incident details

All systems operational

Nigeria: "Invalid transaction details" error

Resolved
Degraded performance
Started 1 day agoLasted 1 day

Affected

Merchant Tools

Degraded performance from 8:30 AM to 3:28 PM

Checkout

Degraded performance from 8:30 AM to 3:28 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Some customers might encounter an “Invalid transaction details” error when attempting to initialize new transactions. This issue appears to affect a subset of merchants and may prevent successful transactions through the Paystack Checkout

    Our engineering team is currently investigating the root cause and working to resolve the issue as quickly as possible.