Paystack - Nigeria: Downtime on Verve card transactions – Incident details

All systems operational

Nigeria: Downtime on Verve card transactions

Resolved
Partial outage
Started about 4 hours agoLasted about 3 hours

Affected

Transactions

Major outage from 8:43 AM to 11:20 AM

NIGERIA

Major outage from 8:43 AM to 11:20 AM

Cards

Major outage from 8:43 AM to 11:20 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently observing a higher failure rate on transactions made with Verve cards.

    Our team has notified the Verve team and we are working closely with them to resolve the issue. We’ll provide updates as soon as normal service is restored.